Cannot make OpenAI work on Ubuntu or Lubuntu


#1

I tried installing OpenAI-Universe at :

Lubuntu
Lubuntu at Virtual box
Ubuntu at Virtual box
In all 3 cases, it failed. Same error : iptables v1.6.0: host/network `run’ not found
Same error : https://github.com/openai/universe/issues/182

On my nameserver, i had :

nameserver 127.0.0.53

I commented it, and same error. Changed to google DNS, same error.

I eventually gave up. Im wondering if OpenAI Universe works only with MAC… This issue is opened since may and nothing?

Just wondering and a bit frustrated.
Is there anything i can do to make it work ?


At every attempt, i did the following ->

  • Clean install with ubuntu-17.04-desktop-amd64.iso or lubuntu-17.04-desktop-amd64.iso

  • pip install numpy

  • sudo apt-get install golang libjpeg-turbo8-dev make

  • sudo apt-get install docker.io

Then …

git clone https://github.com/openai/universe.git
cd universe
pip install -e .

Then I create a file named, Example.py with the following :

import gym
import universe  # register the universe environments

env = gym.make('flashgames.DuskDrive-v0')
env.configure(remotes=1)  # automatically creates a local docker container
observation_n = env.reset()

while True:
  action_n = [[('KeyEvent', 'ArrowUp', True)] for ob in observation_n]  # your agent here
  observation_n, reward_n, done_n, info = env.step(action_n)
  env.render()

Is OpenAI only working with Mac?
Im a linux/windows user. What should I do to use OpenAI ?


#2

Through a bit of pain I,managed to get it working on ubuntu 14.04, however no luck on 16.04, unfortunately you might either need to downgrade or try out docker.

I do want to sit down and figure out how to get it working on more recent ubuntus, but am still in the midst of projects for school