Having problem running my first code


#1

I’m not usually one to post on forums because I like finding answers to my own problems but this one has just worn me down. I am new to using the terminal so everything looks like latin to me when it spits back errors.

Long story short: I was following along with a basic tutorial and tried to run my first program with universe and after executing
(I am running MacOs Sierra)

Zions-MacBook-Air:universe zionenglish$ python demo.py

I got this

Traceback (most recent call last):
File “demo.py”, line 2, in
import universe # register the universe environments
File “/Users/zionenglish/universe/universe/init.py”, line 22, in
from universe import error, envs
File “/Users/zionenglish/universe/universe/envs/init.py”, line 1, in
import universe.envs.vnc_env
File “/Users/zionenglish/universe/universe/envs/vnc_env.py”, line 11, in
from universe.envs import diagnostics
File “/Users/zionenglish/universe/universe/envs/diagnostics.py”, line 2, in
import fastzbarlight
File “//anaconda/lib/python3.6/site-packages/fastzbarlight/init.py”, line 7, in
from ._zbarlight import zbar_code_scanner
ImportError: dlopen(//anaconda/lib/python3.6/site-packages/fastzbarlight/_zbarlight.cpython-36m-darwin.so, 2): Symbol not found: _iconv
Referenced from: //anaconda/lib/python3.6/site-packages/fastzbarlight/_zbarlight.cpython-36m-darwin.so
Expected in: flat namespace
in //anaconda/lib/python3.6/site-packages/fastzbarlight/_zbarlight.cpython-36m-darwin.so

From my understanding this has to do with the installation of universe or gym ? but i reinstalled both of those and I did get a different result. Also I tried to uninstall anaconda (which I do not think I properly did) but that did not work either.

Any help is greatly appreciated!

thanks, zion


#2

Hi, i have the same issue if i want import universe.

I followed this guide: https://medium.com/@alexbhandari/openai-universe-getting-started-on-mac-52d601ef9161#.o5iqw2p8s.

I deinstalled all and installed again but overtime the same issue. My Os is OS X Yosemite.


#3

having the same problem… running MacOs Sierra as well…=\