[Solved] Can't start up 1st agent? Driver issue? Need help!


#1

Hello :slight_smile:
I’m working on getting started with universe and openai, but can’t seem to get the window to popup.
The error is posted below, and all the googling I do leads me to issues with steam.

I’m unsure now to proceed, and am hoping someone can help me out.

016/12/11 23:55:54 I1211 23:55:54.126739 2662 gymvnc.go:550] [0:localhost:5900] connection established

while True:
… action_n = [[(‘KeyEvent’, ‘ArrowUp’, True)] for ob in observation_n] # your agent here
… observation_n, reward_n, done_n, info = env.step(action_n)
… env.render()

universe-TlrFD8-0 | [2016-12-12 05:55:54,141] [INFO:universe.rewarder.remote] Client connecting: peer=tcp4:127.0.0.1:46440 observer=False
universe-TlrFD8-0 | [2016-12-12 05:55:54,141] [INFO:universe.rewarder.remote] WebSocket connection established
libGL error: unable to load driver: radeonsi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
libEGL warning: DRI2: failed to open radeonsi (search paths /usr/lib/x86_64-linux-gnu/dri:${ORIGIN}/dri:/usr/lib/dri)
libEGL warning: DRI2: failed to open swrast (search paths /usr/lib/x86_64-linux-gnu/dri:${ORIGIN}/dri:/usr/lib/dri)
2016/12/11 23:55:54 C1211 23:55:54.515149 2662 vncgl.go:40] failed to initialize glfw: APIUnavailable: EGL: Failed to initialize EGL: EGL is not or could not be initialized


#2

Wanted to bump this. I’m currently having the same issue and actively looking into it.

Running in an Ubuntu 16.04 LTS VM hosted on a Windows Virtualbox. Rest of the install process went fine, but the render window fails to load. I am able to run the glxgears demo and the swrast exists, wondering if it’s just looking in the wrong place?


#3

I’m running mint 18, fresh install onto a new SSD. Everything went fine with the install.
Is there a path we can change? I haven’t tried any other examples yet.


#4

Update, not sure how to edit my previous comment. Went to the file directory it’s looking at the the driver exists.

Error from universe on the left, directory on the right.

EDIT: So I found out how to edit. I also think this might be a permissions problem, but if I run as sudo python script.py. It can’t get the imports. I changed the drivers to 777 but that doesn’t work either.


#5

So, I resolved my driver issues. I had to install the guest additions for VirtualBox, turn on 3d acceleration, and make sure the linux-headers-generic was updated. Looks like the end result of that was it added a new driver that replaced the vboxvideo_dri.so with virtio_gpu_dri.so

Now seeing the following:
2016/12/12 11:09:55 C1212 11:09:55.645191 3644 vncgl.go:40] failed to initialize glfw: APIUnavailable: EGL: Failed to get EGL display: Success


Virtualbox install differences?
#6

Hmm it looks like I have both of those drivers installed (right picture above). I’m also receiving that error, but it’s after the Unable to load driver (left picture above).


#7

Solved the issue:

Had to go to my anadonda3/lib folder and remove 2 files.

libstdc++.so.6
libgcc_s.so.1

I ended up just adding the .ext BAK to the files just in case.

The flash window will now popup, but the mouse just moves between 2 places and never hits start.
That is an unrelated issue though.

Hope this helps!


#9

Hi, I post the similar problem in github #54. I did not use any VMware or Anaconda so the solution above doesn’t work for me. I think my problem is that the Nvidia OpenGL driver does not work with the go-vncdriver. Here is the test:

  1. NVidia TitanX driver + Nvidia OpenGL library I got error:

failed to initialize glfw: APIUnavailable: EGL: Failed to initialize EGL: EGL is not or could not be initialized

  1. Nvidia TitanX driver without OpenGL library I got the following error:
    failed to initialize glfw: APIUnavailable: GLX: GLX extension not found

Therefore, it seems to me I need a right OpenGL library to run the universe. Can suggest how to use the Nvidia OpenGL driver with universe together?

Here is my computer Spec:
CPU: I5-2400
GPU: Nvidia Titan-X
OS: Ubuntu 14.04
Nvidia Driver: Latest 375.26


#10

Adding the .bak extension to libstdc++.so.6 and libgcc_s.so.1 filenames in anaconda3/lib/ directory worked for me.

I’m using Ubuntu 16.10 with Anaconda and python 3.6
Thanks for finding a solution, @ozarka30 .